Spa Heater Burnout

On New Year’s Day we used the spa and I noticed it was losing heat while it was open even though I had turned up the thermostat while we were using it. I noticed a day or two later that the temperature was dropping and also that the electricity use was lower.

1 Day Wired Water Temperature Sensor
31 day wired temperature sensor
31 day wired temperature sensor
Efergy Electrical Use for Spa in Nov.
Efergy Electrical Use for Spa in Nov.
Efergy Electricial Use in Jan.
Efergy Electricial Use in Jan.
Tesla total energy on Jan 1
Tesla total energy on Jan 1
Tesla total energy use Jan 2nd
Tesla total energy use Jan 2nd

Unfortunately I tried to order a new heater but I had the wrong email address then we went out of town and I didn’t notice that my message bounced. Then I sent it again with full images and they bounced from a full mailbox. Probably because the images were too large. Finally after our return home I was able to send an email to the right address and with text information and order a new heater. I hope it gets here quickly as the water temperature is only in the 40’s.

While we were gone half of the lid blew completely off. That is a first. The cover is wearing out and the strap holding it down tore off. So the little heat the spa was holding was lost and it has not regained temperature. It appears that both heaters may be shot at this point because the two lower indicator lights are not lighting up.

Megatrol Indicator Lights
Megatrol Indicator Lights

I’m hoping we can get it fixed before it has to be drained to keep it from freezing.

This entry was posted in -Chronological Recent Posts, Maintenance and Repair, Monitoring, Spa. Bookmark the permalink.